Stacks Image 908

Overview of dittoGUI, Main Window and Menus

dittoGUI is designed to be as quick and easy to use as possible. The setting as well as the preferences are save helping with repeated tasks. Set once and forget.

The Main Window

dittoGUI has two types of windows, the Main Window and the Results Window. When all windows are closed the App will Quit.
Stacks Image 869
Stacks Image 935

The Main Window

The Main window has 4 controls, the Source drop zone, the destination drop zone, the settings cog and the dittoGUI button.

In the Window there is the Source drop zone, where you drag and drop the Source files and folders. This zone can have multiple folders and files.

The Destination drop zone is where you drag and drop the target folder you wish to have the source merge into. It can only have a single Folder.

Once the Source and Destination are set, click the dittoGUI button and the task will begin.

The ditto task is performed in the background and you can continue to use your computer, but it is advisable not to move or edit the files and folders being used by the current ditto task.

If you close all the active windows while there is a ditto process running you will be prompted to terminate the process before quitting.

The Cog button opens the Settings Sheet.
Stacks Image 903
Stacks Image 939

The Menus

ditto on the Edit Menu. This is the same action as clicking the ditto button on the Toolbar.
It has the keyboard shortcut Command-D.

The File Menu's Close command closes the Main Window which may quit dittoGUI.
Preferences in the dittoGUI menu opens the Preferences Panel.

The dittoGUI menu in the Window menu, displays the Main Window, both if it has been closed or has become hidden behind other windows.

All other Menu Items are disabled.